Tag Archives: console

How to access HP’s ILO remote console via SSH

Reading Time: 2 minutes

This will be a quick reminder for myself on how you can remote console via SSH on HP Blade Server and Standalone Servers 🙂

1. Connect to the ilo using SSH, Whether its with PuTTy (Windows) or Terminal (MacOSX or Linux) with the super or admin user and pass.
ssh [email protected]_address

[[email protected] ~]$ ssh 10.2.0.21 -l Administrator
[email protected]'s password: 
User:Administrator logged-in to ILO----n.(10.2.0.21)
iLO 2 Standard Blade Edition 2.25 at 16:36:26 Apr 14 2014
Server Name: vMX-Bay1
Server Power: On

hpiLO-> 

2. Having entered onto the server now via ilo, you will be able to connect to the remote console by either using the commands TEXTCONS or VSP

TEXTCONS

TEXTCONS is short for text console. When I used TEXTCONS, I got this output Monitor is in graphics mode or an unsupported text mode.

hpiLO-> TEXTCONS

Starting text console.
Press 'ESC (' to return to the CLI Session.

hpiLO-> 

Monitor is in graphics mode or an unsupported text mode.

From some quick reading it appears that some OS do not supported access using TEXTCONS, which is no help for me, however this is one way!

VSP

VSP is Virtual Serial Port. As the name suggests it is the virtual port, that is the same as, if you connected a serial cable onto the server. This worked a treat for me, so I am happy now 😀

hpiLO-> VSP

Starting virtual serial port.
Press 'ESC (' to return to the CLI Session.

hpiLO-> Virtual Serial Port active: IO=0x03F8 INT=4

Ubuntu 14.04.2 LTS lab13 ttyS0

lab13 login: 

Job done 🙂

Other CLI commands available:

HP CLI Commands:

POWER    : Control server power.
UID      : Control Unit-ID light.
NMI      : Generate an NMI.
VM       : Virtual media commands.
VSP      : Invoke virtual serial port.
VSP LOG  : Invoke virtual serial port data logging.
TEXTCONS : Invoke Remote Text Console on supported platforms.
NOTE
It is important to note as well, there some OS that don’t support TEXTCONS or VSP. I had installed ESXi 6 on the blade and although it didn’t give me an error I wasn’t able to get any output. So this can be a little hit and miss at times. Its something I probably should look into but when i have some time in the future!
Share this:
Share